안드로이드 P, 낮은 API Level 적용 앱들이 작동하지 않을 수 있다.


안드로이드의 최신 버전 안드로이드 P 프리뷰버전에서 새로운 부분이 발견되었습니다.


안드로이드 P의 경우 최소 API 버전이 17 (젤리빈 4.2) 로 설정되어 있으며, API Level 17 이하의 앱을 실행할 경우 다음과 같은 메세지가 나타날 것입니다.



"이 앱은 이전 버전의 안드로이드 용으로 제작되었으므로 제대로 동작하지 않을 수 있습니다. 업데이트하거나 개발자에게 문의하십시오."



구글은 새로 업로드된 앱에 대한 최소 API 레벨을 설정하여 플레이 스토어 앱을 최신 상태로 유지하는데 전념하고 있으며,


이 정책이 적용될 경우 새로 제출될 앱들은 최신 안드로이드 버전에서 작동하게 될 것이지만 이미 사용 중인 앱들은 업데이트되지 않을 수 있습니다.




오래된 안드로이드 API 적용 앱들이 작동하지 않을 수 있다 (GSMArena, https://www.gsmarena.com/older_android_apps_may_stop_working_after_android_p-news-30149.php)



이 글을 공유하기


댓글(0)

Designed by CMSFactory.NET